[v2,01/20] tests: Add a missing iostream include
diff mbox series

Message ID 20240830152721.1420313-2-mzamazal@redhat.com
State Accepted
Headers show
Series
  • Remove unused includes
Related show

Commit Message

Milan Zamazal Aug. 30, 2024, 3:26 p.m. UTC
generated_serializer_test.cpp uses iostream without including it,
relying on imports from another included header.  Let's include iostream
there.

Signed-off-by: Milan Zamazal <mzamazal@redhat.com>
---
 .../generated_serializer/generated_serializer_test.cpp           | 1 +
 1 file changed, 1 insertion(+)

Comments

Laurent Pinchart Aug. 31, 2024, 12:17 a.m. UTC | #1
On Fri, Aug 30, 2024 at 05:26:58PM +0200, Milan Zamazal wrote:
> generated_serializer_test.cpp uses iostream without including it,
> relying on imports from another included header.  Let's include iostream

Double space.

> there.
> 
> Signed-off-by: Milan Zamazal <mzamazal@redhat.com>

Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>

> ---
>  .../generated_serializer/generated_serializer_test.cpp           | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/test/serialization/generated_serializer/generated_serializer_test.cpp b/test/serialization/generated_serializer/generated_serializer_test.cpp
> index 4b11d67f..dd696885 100644
> --- a/test/serialization/generated_serializer/generated_serializer_test.cpp
> +++ b/test/serialization/generated_serializer/generated_serializer_test.cpp
> @@ -6,6 +6,7 @@
>   */
>  
>  #include <algorithm>
> +#include <iostream>
>  #include <tuple>
>  #include <vector>
>
Milan Zamazal Sept. 2, 2024, 9:49 a.m. UTC | #2
Hi Laurent,

thank you for review.

Laurent Pinchart <laurent.pinchart@ideasonboard.com> writes:

> On Fri, Aug 30, 2024 at 05:26:58PM +0200, Milan Zamazal wrote:
>> generated_serializer_test.cpp uses iostream without including it,
>> relying on imports from another included header.  Let's include iostream
>
> Double space.

This is intentional.  Emacs uses this (American?) style to distinguish
sentences from abbreviations (and there are opinions that it is better
readable on computer screens).  I don't use it in source code comments
but use it elsewhere.

>> there.
>> 
>> Signed-off-by: Milan Zamazal <mzamazal@redhat.com>
>
> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
>
>> ---
>>  .../generated_serializer/generated_serializer_test.cpp           | 1 +
>>  1 file changed, 1 insertion(+)
>> 
>> diff --git a/test/serialization/generated_serializer/generated_serializer_test.cpp b/test/serialization/generated_serializer/generated_serializer_test.cpp
>> index 4b11d67f..dd696885 100644
>> --- a/test/serialization/generated_serializer/generated_serializer_test.cpp
>> +++ b/test/serialization/generated_serializer/generated_serializer_test.cpp
>> @@ -6,6 +6,7 @@
>>   */
>>  
>>  #include <algorithm>
>> +#include <iostream>
>>  #include <tuple>
>>  #include <vector>
>>
Laurent Pinchart Sept. 2, 2024, 12:34 p.m. UTC | #3
On Mon, Sep 02, 2024 at 11:49:52AM +0200, Milan Zamazal wrote:
> Laurent Pinchart writes:
> > On Fri, Aug 30, 2024 at 05:26:58PM +0200, Milan Zamazal wrote:
> >> generated_serializer_test.cpp uses iostream without including it,
> >> relying on imports from another included header.  Let's include iostream
> >
> > Double space.
> 
> This is intentional.  Emacs uses this (American?) style to distinguish
> sentences from abbreviations (and there are opinions that it is better
> readable on computer screens).  I don't use it in source code comments
> but use it elsewhere.

So the Americans messed up not just the spelling, for also the
typography ? :-) Jokes aside, you should switch to vim. Jokes aside
again, I won't insist on reformatting commit messages for that, even if
it looks completely alien to me (and thus hinders readability). It would
be more annoying in comments in code or in documentation.

> >> there.
> >> 
> >> Signed-off-by: Milan Zamazal <mzamazal@redhat.com>
> >
> > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> >
> >> ---
> >>  .../generated_serializer/generated_serializer_test.cpp           | 1 +
> >>  1 file changed, 1 insertion(+)
> >> 
> >> diff --git a/test/serialization/generated_serializer/generated_serializer_test.cpp b/test/serialization/generated_serializer/generated_serializer_test.cpp
> >> index 4b11d67f..dd696885 100644
> >> --- a/test/serialization/generated_serializer/generated_serializer_test.cpp
> >> +++ b/test/serialization/generated_serializer/generated_serializer_test.cpp
> >> @@ -6,6 +6,7 @@
> >>   */
> >>  
> >>  #include <algorithm>
> >> +#include <iostream>
> >>  #include <tuple>
> >>  #include <vector>
> >>
Milan Zamazal Sept. 2, 2024, 4:32 p.m. UTC | #4
Laurent Pinchart <laurent.pinchart@ideasonboard.com> writes:

> On Mon, Sep 02, 2024 at 11:49:52AM +0200, Milan Zamazal wrote:
>> Laurent Pinchart writes:
>> > On Fri, Aug 30, 2024 at 05:26:58PM +0200, Milan Zamazal wrote:
>
>> >> generated_serializer_test.cpp uses iostream without including it,
>> >> relying on imports from another included header.  Let's include iostream
>> >
>> > Double space.
>> 
>> This is intentional.  Emacs uses this (American?) style to distinguish
>> sentences from abbreviations (and there are opinions that it is better
>> readable on computer screens).  I don't use it in source code comments
>> but use it elsewhere.
>
> So the Americans messed up not just the spelling, for also the
> typography ? :-) Jokes aside, you should switch to vim. 

Last time I tried I couldn't move around using my Dvorak keyboard. :-)

> Jokes aside again, I won't insist on reformatting commit messages for
> that, even if it looks completely alien to me

It seems larger spaces after sentences become old fashioned.  But it's
no way something exotic, it's what e.g. TeX uses by default IIRC (and
yes, it can be changed with \frenchspacing, to make us all happy :-)).

> (and thus hinders readability).

I'd say what really hinders readability is using camelCase in a language
that uses snake_case in its standard library ;-).

> It would be more annoying in comments in code or in documentation.

Yes, where consistency is needed, it should be respected.

>> >> there.
>> >> 
>> >> Signed-off-by: Milan Zamazal <mzamazal@redhat.com>
>> >
>> > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
>> >
>> >> ---
>> >>  .../generated_serializer/generated_serializer_test.cpp           | 1 +
>> >>  1 file changed, 1 insertion(+)
>> >> 
>> >> diff --git a/test/serialization/generated_serializer/generated_serializer_test.cpp b/test/serialization/generated_serializer/generated_serializer_test.cpp
>> >> index 4b11d67f..dd696885 100644
>> >> --- a/test/serialization/generated_serializer/generated_serializer_test.cpp
>> >> +++ b/test/serialization/generated_serializer/generated_serializer_test.cpp
>> >> @@ -6,6 +6,7 @@
>> >>   */
>> >>  
>> >>  #include <algorithm>
>> >> +#include <iostream>
>> >>  #include <tuple>
>> >>  #include <vector>
>> >>

Patch
diff mbox series

diff --git a/test/serialization/generated_serializer/generated_serializer_test.cpp b/test/serialization/generated_serializer/generated_serializer_test.cpp
index 4b11d67f..dd696885 100644
--- a/test/serialization/generated_serializer/generated_serializer_test.cpp
+++ b/test/serialization/generated_serializer/generated_serializer_test.cpp
@@ -6,6 +6,7 @@ 
  */
 
 #include <algorithm>
+#include <iostream>
 #include <tuple>
 #include <vector>