Message ID | 20210715112845.4049846-1-kieran.bingham@ideasonboard.com |
---|---|
State | Accepted |
Headers | show |
Series |
|
Related | show |
Hi Kieran, Thank you for the patch. On Thu, Jul 15, 2021 at 12:28:45PM +0100, Kieran Bingham wrote: > In libcamera commit 6a31a8d8e274 ("libcamera: buffer: Rename buffer.h to > framebuffer.h"), the public header buffer.h was renamed. > > Update the usage accordingly. > > Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> > --- > include/libcamera-helpers/mapped_buffer.h | 2 +- > ipu3.cpp | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/include/libcamera-helpers/mapped_buffer.h b/include/libcamera-helpers/mapped_buffer.h > index b34a70c5f2c5..6cfc57217d75 100644 > --- a/include/libcamera-helpers/mapped_buffer.h > +++ b/include/libcamera-helpers/mapped_buffer.h > @@ -13,7 +13,7 @@ > #include <libcamera/base/class.h> > #include <libcamera/base/span.h> > > -#include <libcamera/buffer.h> > +#include <libcamera/framebuffer.h> > > namespace libcamera { > > diff --git a/ipu3.cpp b/ipu3.cpp > index e0e87a8d70ec..651e0bb5efc1 100644 > --- a/ipu3.cpp > +++ b/ipu3.cpp > @@ -11,8 +11,8 @@ > #include <linux/intel-ipu3.h> > #include <linux/v4l2-controls.h> > > -#include <libcamera/buffer.h> > #include <libcamera/control_ids.h> > +#include <libcamera/framebuffer.h> > #include <libcamera/ipa/ipa_interface.h> > #include <libcamera/ipa/ipa_module_info.h> > #include <libcamera/ipa/ipu3_ipa_interface.h>
Hi Laurent, On 15/07/2021 12:37, Laurent Pinchart wrote: > Hi Kieran, > > Thank you for the patch. > > On Thu, Jul 15, 2021 at 12:28:45PM +0100, Kieran Bingham wrote: >> In libcamera commit 6a31a8d8e274 ("libcamera: buffer: Rename buffer.h to >> framebuffer.h"), the public header buffer.h was renamed. >> >> Update the usage accordingly. >> >> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> > > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Thanks, I'll integrate this as an immediate fix. I've now added the IPA to my daily build system, so it will be rebuilt against any libcamera updates, and I'll catch this sooner next time. (Looks like it's taken me 4 days to notice this !) -- Kieran > >> --- >> include/libcamera-helpers/mapped_buffer.h | 2 +- >> ipu3.cpp | 2 +- >> 2 files changed, 2 insertions(+), 2 deletions(-) >> >> diff --git a/include/libcamera-helpers/mapped_buffer.h b/include/libcamera-helpers/mapped_buffer.h >> index b34a70c5f2c5..6cfc57217d75 100644 >> --- a/include/libcamera-helpers/mapped_buffer.h >> +++ b/include/libcamera-helpers/mapped_buffer.h >> @@ -13,7 +13,7 @@ >> #include <libcamera/base/class.h> >> #include <libcamera/base/span.h> >> >> -#include <libcamera/buffer.h> >> +#include <libcamera/framebuffer.h> >> >> namespace libcamera { >> >> diff --git a/ipu3.cpp b/ipu3.cpp >> index e0e87a8d70ec..651e0bb5efc1 100644 >> --- a/ipu3.cpp >> +++ b/ipu3.cpp >> @@ -11,8 +11,8 @@ >> #include <linux/intel-ipu3.h> >> #include <linux/v4l2-controls.h> >> >> -#include <libcamera/buffer.h> >> #include <libcamera/control_ids.h> >> +#include <libcamera/framebuffer.h> >> #include <libcamera/ipa/ipa_interface.h> >> #include <libcamera/ipa/ipa_module_info.h> >> #include <libcamera/ipa/ipu3_ipa_interface.h> >
Hi Kieran, On 15/07/2021 13:28, Kieran Bingham wrote: > In libcamera commit 6a31a8d8e274 ("libcamera: buffer: Rename buffer.h to > framebuffer.h"), the public header buffer.h was renamed. > > Update the usage accordingly. > > Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Jean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com> > --- > include/libcamera-helpers/mapped_buffer.h | 2 +- > ipu3.cpp | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/include/libcamera-helpers/mapped_buffer.h b/include/libcamera-helpers/mapped_buffer.h > index b34a70c5f2c5..6cfc57217d75 100644 > --- a/include/libcamera-helpers/mapped_buffer.h > +++ b/include/libcamera-helpers/mapped_buffer.h > @@ -13,7 +13,7 @@ > #include <libcamera/base/class.h> > #include <libcamera/base/span.h> > > -#include <libcamera/buffer.h> > +#include <libcamera/framebuffer.h> > > namespace libcamera { > > diff --git a/ipu3.cpp b/ipu3.cpp > index e0e87a8d70ec..651e0bb5efc1 100644 > --- a/ipu3.cpp > +++ b/ipu3.cpp > @@ -11,8 +11,8 @@ > #include <linux/intel-ipu3.h> > #include <linux/v4l2-controls.h> > > -#include <libcamera/buffer.h> > #include <libcamera/control_ids.h> > +#include <libcamera/framebuffer.h> > #include <libcamera/ipa/ipa_interface.h> > #include <libcamera/ipa/ipa_module_info.h> > #include <libcamera/ipa/ipu3_ipa_interface.h> >
Hi Kieran, On 7/15/21 5:11 PM, Kieran Bingham wrote: > Hi Laurent, > > On 15/07/2021 12:37, Laurent Pinchart wrote: >> Hi Kieran, >> >> Thank you for the patch. >> >> On Thu, Jul 15, 2021 at 12:28:45PM +0100, Kieran Bingham wrote: >>> In libcamera commit 6a31a8d8e274 ("libcamera: buffer: Rename buffer.h to >>> framebuffer.h"), the public header buffer.h was renamed. >>> >>> Update the usage accordingly. >>> >>> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> LGTM too. >> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> > Thanks, I'll integrate this as an immediate fix. > > I've now added the IPA to my daily build system, so it will be rebuilt > against any libcamera updates, and I'll catch this sooner next time. > > (Looks like it's taken me 4 days to notice this !) Yes, it was on my to-do list to ensure if rename patches have been merged, handle this as well. Thanks for handling them while I was away! > -- > Kieran > > >>> --- >>> include/libcamera-helpers/mapped_buffer.h | 2 +- >>> ipu3.cpp | 2 +- >>> 2 files changed, 2 insertions(+), 2 deletions(-) >>> >>> diff --git a/include/libcamera-helpers/mapped_buffer.h b/include/libcamera-helpers/mapped_buffer.h >>> index b34a70c5f2c5..6cfc57217d75 100644 >>> --- a/include/libcamera-helpers/mapped_buffer.h >>> +++ b/include/libcamera-helpers/mapped_buffer.h >>> @@ -13,7 +13,7 @@ >>> #include <libcamera/base/class.h> >>> #include <libcamera/base/span.h> >>> >>> -#include <libcamera/buffer.h> >>> +#include <libcamera/framebuffer.h> >>> >>> namespace libcamera { >>> >>> diff --git a/ipu3.cpp b/ipu3.cpp >>> index e0e87a8d70ec..651e0bb5efc1 100644 >>> --- a/ipu3.cpp >>> +++ b/ipu3.cpp >>> @@ -11,8 +11,8 @@ >>> #include <linux/intel-ipu3.h> >>> #include <linux/v4l2-controls.h> >>> >>> -#include <libcamera/buffer.h> >>> #include <libcamera/control_ids.h> >>> +#include <libcamera/framebuffer.h> >>> #include <libcamera/ipa/ipa_interface.h> >>> #include <libcamera/ipa/ipa_module_info.h> >>> #include <libcamera/ipa/ipu3_ipa_interface.h>
diff --git a/include/libcamera-helpers/mapped_buffer.h b/include/libcamera-helpers/mapped_buffer.h index b34a70c5f2c5..6cfc57217d75 100644 --- a/include/libcamera-helpers/mapped_buffer.h +++ b/include/libcamera-helpers/mapped_buffer.h @@ -13,7 +13,7 @@ #include <libcamera/base/class.h> #include <libcamera/base/span.h> -#include <libcamera/buffer.h> +#include <libcamera/framebuffer.h> namespace libcamera { diff --git a/ipu3.cpp b/ipu3.cpp index e0e87a8d70ec..651e0bb5efc1 100644 --- a/ipu3.cpp +++ b/ipu3.cpp @@ -11,8 +11,8 @@ #include <linux/intel-ipu3.h> #include <linux/v4l2-controls.h> -#include <libcamera/buffer.h> #include <libcamera/control_ids.h> +#include <libcamera/framebuffer.h> #include <libcamera/ipa/ipa_interface.h> #include <libcamera/ipa/ipa_module_info.h> #include <libcamera/ipa/ipu3_ipa_interface.h>
In libcamera commit 6a31a8d8e274 ("libcamera: buffer: Rename buffer.h to framebuffer.h"), the public header buffer.h was renamed. Update the usage accordingly. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> --- include/libcamera-helpers/mapped_buffer.h | 2 +- ipu3.cpp | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)