[libcamera-devel,v3,0/2] libcamera: geometry: Add isNull() function to Size class
mbox series

Message ID 20200628190920.3206340-1-niklas.soderlund@ragnatech.se
Headers show
Series
  • libcamera: geometry: Add isNull() function to Size class
Related show

Message

Niklas Söderlund June 28, 2020, 7:09 p.m. UTC
Hi,

This is mainly Laurent's work I have just collected the tags and added a 
small patch on-top to make use of it in the IPU3 pipeline handler. I 
know the name of the helper (isNull vs isZero vs isValid vs isEmpty) is 
still debated but I did not wish to lose track of where in the CIO2 the 
helper should be used disregarding its final name.

If I understand things correctly Laurent and myself prefer isNull() 
while Jacopo and Kieran seems fine with isNull() but would prefer 
isValid() and isZero() respectively. In other words the perfect bikeshed 
is almost built :-)

Laurent Pinchart (1):
  libcamera: geometry: Add isNull() function to Size class

Niklas Söderlund (1):
  libcamera: ipu3: cio2: Use Size::isNull()

 include/libcamera/geometry.h         |  1 +
 src/libcamera/geometry.cpp           |  6 ++++++
 src/libcamera/pipeline/ipu3/cio2.cpp |  2 +-
 test/geometry.cpp                    | 10 ++++++++++
 4 files changed, 18 insertions(+), 1 deletion(-)