[libcamera-devel,v3,0/3] Add a V4L2PixelFormat class
mbox series

Message ID 20200319132919.9563-1-laurent.pinchart@ideasonboard.com
Headers show
Series
  • Add a V4L2PixelFormat class
Related show

Message

Laurent Pinchart March 19, 2020, 1:29 p.m. UTC
Hello,

This small patch series builds on top of Niklas' PixelFormat work to
introduce the V4L2 counterpart of the PixelFormat class.

The class should be extended for a lookup table of pixel format names to
improve the toString() method. Other helper methods to retrieve format
information should probably be added too, hopefully removing some of the
data from the pixelFormatInfo array in v4l2_camera_proxy. Ideas on how
to split pixel format information and conversion between the
PixelFormat, V4L2PixelFormat and V4L2VideoDevice classes are welcome

Laurent Pinchart (3):
  libcamera: v4l2_videodevice: Add V4L2PixelFormat class
  libcamera: v4l2_videodevice: Rename toV4L2Fourcc to toV4L2PixelFormat
  libcamera: v4l2_videodevice: Make V4L2PixelFormat constructor explicit

 src/libcamera/include/v4l2_videodevice.h      |  39 +++--
 src/libcamera/pipeline/ipu3/ipu3.cpp          |  16 +--
 src/libcamera/pipeline/rkisp1/rkisp1.cpp      |   8 +-
 src/libcamera/pipeline/uvcvideo.cpp           |   8 +-
 src/libcamera/pipeline/vimc.cpp               |   6 +-
 src/libcamera/v4l2_videodevice.cpp            | 135 +++++++++++++-----
 test/libtest/buffer_source.cpp                |   3 +-
 .../v4l2_videodevice_test.cpp                 |   2 +-
 8 files changed, 153 insertions(+), 64 deletions(-)