[v2,0/2] Raspberry Pi: Fix algorithm gating
mbox series

Message ID 20260805141156.2092208-1-naush@raspberrypi.com
Headers show
Series
  • Raspberry Pi: Fix algorithm gating
Related show

Message

Naushir Patuck Aug. 5, 2026, 2:09 p.m. UTC
Hi,

Quick turnaround for v2 with the following minor changes:

- Patch 1 adds some comment re-wording that I missed.
- Patch 1 also renames mistrustFramesModeSwitch().
- Patch 2 fixes some mis-spellings in the commit message.

Regards,
Naush

Naushir Patuck (2):
  ipa: rpi: Rename mistrustFrames* to mistrustMetadata*
  ipa: rpi: Gate CamHelper::prepare() by the mistrust count

 src/ipa/rpi/cam_helper/cam_helper.cpp        |  6 ++---
 src/ipa/rpi/cam_helper/cam_helper.h          | 16 ++++++------
 src/ipa/rpi/cam_helper/cam_helper_imx219.cpp |  4 +--
 src/ipa/rpi/cam_helper/cam_helper_imx355.cpp |  4 +--
 src/ipa/rpi/cam_helper/cam_helper_ov5647.cpp |  8 +++---
 src/ipa/rpi/common/ipa_base.cpp              | 26 ++++++++------------
 6 files changed, 29 insertions(+), 35 deletions(-)