[00/15] libipa: awb: Drive-by fixes
mbox series

Message ID 20250223230403.1226-1-laurent.pinchart@ideasonboard.com
Headers show
Series
  • libipa: awb: Drive-by fixes
Related show

Message

Laurent Pinchart Feb. 23, 2025, 11:03 p.m. UTC
Hello everybody,

While having a look at the recently merged bayesian AWB support, I
noticed a bunch of minor issues. This patch series fixes them. There's
not much else to say here, please see individual patches for details.

Laurent Pinchart (15):
  libipa: awb: Sort class member documentation according to header order
  libipa: awb: Capitalize AWB
  libipa: awb: Follow function names with '()' in doxygen documentation
  libipa: awb: Standardize spelling on 'grey' world
  libipa: awb: Replace reference to pipeline handle with IPA module
  libipa: awb: Pass lux value to calculateAwb() as unsigned int
  ipa: rkisp1: awb: Fix wrong indentation in comment
  libipa: awb: Rename AwbStats::getRGBMeans() to rgbMeans()
  libipa: awb: Make controls_ member variable private
  libipa: awb: Provide read-only accessor to modes_
  libipa: awb: Tidy up includes
  libipa: awb_grey: Minor comment fixes
  ipa: rkisp1: awb: Don't calculate RGB means if stats are missing
  ipa: rkisp1: awb: Capitalize AWB
  libcamera: Drop spurious colon after doxygen \todo directive

 src/ipa/libipa/awb.cpp                        | 85 +++++++++----------
 src/ipa/libipa/awb.h                          | 12 ++-
 src/ipa/libipa/awb_bayes.cpp                  | 18 ++--
 src/ipa/libipa/awb_bayes.h                    | 12 +--
 src/ipa/libipa/awb_grey.cpp                   | 20 ++---
 src/ipa/libipa/awb_grey.h                     |  5 +-
 src/ipa/rkisp1/algorithms/awb.cpp             | 21 ++---
 .../converter/converter_v4l2_m2m.cpp          |  2 +-
 src/libcamera/pipeline/mali-c55/mali-c55.cpp  |  2 +-
 .../pipeline/virtual/config_parser.cpp        |  2 +-
 10 files changed, 90 insertions(+), 89 deletions(-)


base-commit: d476f8358be1536d4edd680c6024f784ff022f5d
--
Regards,

Laurent Pinchart