Message ID | 20201020000310.3008-2-laurent.pinchart@ideasonboard.com |
---|---|
State | Accepted |
Headers | show |
Series |
|
Related | show |
Hi Laurent, On Tue, Oct 20, 2020 at 03:03:06AM +0300, Laurent Pinchart wrote: > To be consistent with the other pipeline handlers that don't prefix > their IPA protocol header with ipa_, rename ipa_vimc.h to vimc.h. Aaaah yes, I needed this for IPC. > Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> > --- > include/libcamera/ipa/{ipa_vimc.h => vimc.h} | 2 +- > src/ipa/vimc/vimc.cpp | 2 +- > test/ipa/ipa_interface_test.cpp | 2 +- > 3 files changed, 3 insertions(+), 3 deletions(-) > rename include/libcamera/ipa/{ipa_vimc.h => vimc.h} (88%) > > diff --git a/include/libcamera/ipa/ipa_vimc.h b/include/libcamera/ipa/vimc.h > similarity index 88% > rename from include/libcamera/ipa/ipa_vimc.h > rename to include/libcamera/ipa/vimc.h > index 8e82dd94bf47..22d97992f80f 100644 > --- a/include/libcamera/ipa/ipa_vimc.h > +++ b/include/libcamera/ipa/vimc.h > @@ -2,7 +2,7 @@ > /* > * Copyright (C) 2019, Google Inc. > * > - * ipa_vimc.h - Vimc Image Processing Algorithm module > + * vimc.h - Vimc Image Processing Algorithm module > */ > > #ifndef __LIBCAMERA_IPA_VIMC_H__ > diff --git a/src/ipa/vimc/vimc.cpp b/src/ipa/vimc/vimc.cpp > index 372a15f555cb..cf8411359e40 100644 > --- a/src/ipa/vimc/vimc.cpp > +++ b/src/ipa/vimc/vimc.cpp > @@ -5,7 +5,7 @@ > * ipa_vimc.cpp - Vimc Image Processing Algorithm module > */ > > -#include <libcamera/ipa/ipa_vimc.h> > +#include <libcamera/ipa/vimc.h> > > #include <fcntl.h> > #include <string.h> > diff --git a/test/ipa/ipa_interface_test.cpp b/test/ipa/ipa_interface_test.cpp > index 1bc93a631a63..67488409e7ff 100644 > --- a/test/ipa/ipa_interface_test.cpp > +++ b/test/ipa/ipa_interface_test.cpp > @@ -14,7 +14,7 @@ > > #include <libcamera/event_dispatcher.h> > #include <libcamera/event_notifier.h> > -#include <libcamera/ipa/ipa_vimc.h> > +#include <libcamera/ipa/vimc.h> > #include <libcamera/timer.h> > > #include "libcamera/internal/device_enumerator.h" > -- > Regards, > > Laurent Pinchart > > _______________________________________________ > libcamera-devel mailing list > libcamera-devel@lists.libcamera.org > https://lists.libcamera.org/listinfo/libcamera-devel
On 20/10/2020 01:03, Laurent Pinchart wrote: > To be consistent with the other pipeline handlers that don't prefix > their IPA protocol header with ipa_, rename ipa_vimc.h to vimc.h. > > Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> > --- > include/libcamera/ipa/{ipa_vimc.h => vimc.h} | 2 +- > src/ipa/vimc/vimc.cpp | 2 +- > test/ipa/ipa_interface_test.cpp | 2 +- > 3 files changed, 3 insertions(+), 3 deletions(-) > rename include/libcamera/ipa/{ipa_vimc.h => vimc.h} (88%) > > diff --git a/include/libcamera/ipa/ipa_vimc.h b/include/libcamera/ipa/vimc.h > similarity index 88% > rename from include/libcamera/ipa/ipa_vimc.h > rename to include/libcamera/ipa/vimc.h > index 8e82dd94bf47..22d97992f80f 100644 > --- a/include/libcamera/ipa/ipa_vimc.h > +++ b/include/libcamera/ipa/vimc.h > @@ -2,7 +2,7 @@ > /* > * Copyright (C) 2019, Google Inc. > * > - * ipa_vimc.h - Vimc Image Processing Algorithm module > + * vimc.h - Vimc Image Processing Algorithm module > */ > > #ifndef __LIBCAMERA_IPA_VIMC_H__ > diff --git a/src/ipa/vimc/vimc.cpp b/src/ipa/vimc/vimc.cpp > index 372a15f555cb..cf8411359e40 100644 > --- a/src/ipa/vimc/vimc.cpp > +++ b/src/ipa/vimc/vimc.cpp > @@ -5,7 +5,7 @@ > * ipa_vimc.cpp - Vimc Image Processing Algorithm module > */ > > -#include <libcamera/ipa/ipa_vimc.h> > +#include <libcamera/ipa/vimc.h> > > #include <fcntl.h> > #include <string.h> > diff --git a/test/ipa/ipa_interface_test.cpp b/test/ipa/ipa_interface_test.cpp > index 1bc93a631a63..67488409e7ff 100644 > --- a/test/ipa/ipa_interface_test.cpp > +++ b/test/ipa/ipa_interface_test.cpp > @@ -14,7 +14,7 @@ > > #include <libcamera/event_dispatcher.h> > #include <libcamera/event_notifier.h> > -#include <libcamera/ipa/ipa_vimc.h> > +#include <libcamera/ipa/vimc.h> > #include <libcamera/timer.h> > > #include "libcamera/internal/device_enumerator.h" >
diff --git a/include/libcamera/ipa/ipa_vimc.h b/include/libcamera/ipa/vimc.h similarity index 88% rename from include/libcamera/ipa/ipa_vimc.h rename to include/libcamera/ipa/vimc.h index 8e82dd94bf47..22d97992f80f 100644 --- a/include/libcamera/ipa/ipa_vimc.h +++ b/include/libcamera/ipa/vimc.h @@ -2,7 +2,7 @@ /* * Copyright (C) 2019, Google Inc. * - * ipa_vimc.h - Vimc Image Processing Algorithm module + * vimc.h - Vimc Image Processing Algorithm module */ #ifndef __LIBCAMERA_IPA_VIMC_H__ diff --git a/src/ipa/vimc/vimc.cpp b/src/ipa/vimc/vimc.cpp index 372a15f555cb..cf8411359e40 100644 --- a/src/ipa/vimc/vimc.cpp +++ b/src/ipa/vimc/vimc.cpp @@ -5,7 +5,7 @@ * ipa_vimc.cpp - Vimc Image Processing Algorithm module */ -#include <libcamera/ipa/ipa_vimc.h> +#include <libcamera/ipa/vimc.h> #include <fcntl.h> #include <string.h> diff --git a/test/ipa/ipa_interface_test.cpp b/test/ipa/ipa_interface_test.cpp index 1bc93a631a63..67488409e7ff 100644 --- a/test/ipa/ipa_interface_test.cpp +++ b/test/ipa/ipa_interface_test.cpp @@ -14,7 +14,7 @@ #include <libcamera/event_dispatcher.h> #include <libcamera/event_notifier.h> -#include <libcamera/ipa/ipa_vimc.h> +#include <libcamera/ipa/vimc.h> #include <libcamera/timer.h> #include "libcamera/internal/device_enumerator.h"
To be consistent with the other pipeline handlers that don't prefix their IPA protocol header with ipa_, rename ipa_vimc.h to vimc.h. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> --- include/libcamera/ipa/{ipa_vimc.h => vimc.h} | 2 +- src/ipa/vimc/vimc.cpp | 2 +- test/ipa/ipa_interface_test.cpp | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) rename include/libcamera/ipa/{ipa_vimc.h => vimc.h} (88%)