From patchwork Thu Oct 6 19:55:23 2022 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Laurent Pinchart X-Patchwork-Id: 17553 Return-Path: X-Original-To: parsemail@patchwork.libcamera.org Delivered-To: parsemail@patchwork.libcamera.org Received: from lancelot.ideasonboard.com (lancelot.ideasonboard.com [92.243.16.209]) by patchwork.libcamera.org (Postfix) with ESMTPS id E0B28BD16B for ; Thu, 6 Oct 2022 19:55:30 +0000 (UTC) Received: from lancelot.ideasonboard.com (localhost [IPv6:::1]) by lancelot.ideasonboard.com (Postfix) with ESMTP id 1446F62CF4; Thu, 6 Oct 2022 21:55:30 +0200 (CEST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=libcamera.org; s=mail; t=1665086130; bh=/nrFRiI4Av9jkCUdTfmNCkQUnSxGLN3jJEtZFtDeABE=; h=To:Date:Subject:List-Id:List-Unsubscribe:List-Archive:List-Post: List-Help:List-Subscribe:From:Reply-To:From; b=jA3KERLAqCPuuVQS3R2Cd2t2J6e5z4NflzlRtg41IiKP1HhjX85yqN3pSomd5hbti QDXxqCv87z/VHFD4+DFMr7s/8WNpBfufXp220I1tBezAGTnvNMiJbcOY9K2S+CTPLK fSk1V4fSPREboMXvEir19G3PiPH5g7qFX5/Q6N7UuU7h8j7Hd6TRkel2cNoYtWq/iR NWm5BzqIxtXEz1D7yE8CuDnkt49Mp24DKmOtYMdoAIspd3JLSC/uvot44/ty/nUpuS 7dA4v/YKU29OhhAIZ+g8C9X9tUmChXxYHPyV6GQ1uzroCpULf+5NIZrjPWGB6+Jk+C U8fo0cQoKotYg== Received: from perceval.ideasonboard.com (perceval.ideasonboard.com [213.167.242.64]) by lancelot.ideasonboard.com (Postfix) with ESMTPS id CF20B62CEC for ; Thu, 6 Oct 2022 21:55:28 +0200 (CEST) Authentication-Results: lancelot.ideasonboard.com; dkim=pass (1024-bit key; unprotected) header.d=ideasonboard.com header.i=@ideasonboard.com header.b="NjDZrLIP"; dkim-atps=neutral Received: from pendragon.ideasonboard.com (62-78-145-57.bb.dnainternet.fi [62.78.145.57]) by perceval.ideasonboard.com (Postfix) with ESMTPSA id 2B4224DD for ; Thu, 6 Oct 2022 21:55:28 +0200 (CEST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ideasonboard.com; s=mail; t=1665086128; bh=/nrFRiI4Av9jkCUdTfmNCkQUnSxGLN3jJEtZFtDeABE=; h=From:To:Subject:Date:From; b=NjDZrLIPHQQLiyombLBhYiWGptrU2EI4wr37RRsjv0Vt/n8lrOMH83eTlUunSGBv4 OtPTwUxGH+9dWhwlU/sDRkF2DCXZ+w7nEJbhw4xGJCr/mqQMa/mpIeKI8Dwq4mrgdH qChAZJ6SSvzA4PTcE9rcO24TEUTw1jNvebiZd5HY= To: libcamera-devel@lists.libcamera.org Date: Thu, 6 Oct 2022 22:55:23 +0300 Message-Id: <20221006195523.17739-1-laurent.pinchart@ideasonboard.com> X-Mailer: git-send-email 2.35.1 MIME-Version: 1.0 Subject: [libcamera-devel] [PATCH] libcamera: camera_manager: Rename parameter to get() X-BeenThere: libcamera-devel@lists.libcamera.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-Patchwork-Original-From: Laurent Pinchart via libcamera-devel From: Laurent Pinchart Reply-To: Laurent Pinchart Errors-To: libcamera-devel-bounces@lists.libcamera.org Sender: "libcamera-devel" The CameraManager::get() function takes a string containing the ID of the requested camera. This is correctly documented and implemented in the .cpp file, but the header file names the parameter 'name' instead of 'id'. Fix it. Signed-off-by: Laurent Pinchart Reviewed-by: Umang Jain --- include/libcamera/camera_manager.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/libcamera/camera_manager.h b/include/libcamera/camera_manager.h index 7647c2a1c43c..4b1fb7568e83 100644 --- a/include/libcamera/camera_manager.h +++ b/include/libcamera/camera_manager.h @@ -31,7 +31,7 @@ public: void stop(); std::vector> cameras() const; - std::shared_ptr get(const std::string &name); + std::shared_ptr get(const std::string &id); std::shared_ptr get(dev_t devnum); void addCamera(std::shared_ptr camera,