From patchwork Tue Dec 11 19:10:06 2018 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Laurent Pinchart X-Patchwork-Id: 31 Return-Path: Received: from perceval.ideasonboard.com (perceval.ideasonboard.com [IPv6:2001:4b98:dc2:55:216:3eff:fef7:d647]) by lancelot.ideasonboard.com (Postfix) with ESMTPS id 3EF7760B10 for ; Tue, 11 Dec 2018 20:09:40 +0100 (CET) Received: from avalon.bb.dnainternet.fi (dfj612ybrt5fhg77mgycy-3.rev.dnainternet.fi [IPv6:2001:14ba:21f5:5b00:2e86:4862:ef6a:2804]) by perceval.ideasonboard.com (Postfix) with ESMTPSA id 5F1BE564 for ; Tue, 11 Dec 2018 20:09:39 +0100 (CET) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ideasonboard.com; s=mail; t=1544555379; bh=kQfdXFYxkz4If6UH4SrNW9VyH3TrlPnRvjYzzDW+qe4=; h=From:To:Subject:Date:In-Reply-To:References:From; b=fSMHTkEVpzyq0KtYsiI97fPup1/T1yRrMAoYvwKArK3zpbhofF3u31OHdruxfWEf4 dai5LWIXjI5YdNipmP4lzHL90DmxHtb43ZzBHvWBEgL4zK/8LrP2zc1ll1Gl5tyhey vhkBlGeseHR3jYG0XuuC+En4yjRv+dzkblCip51o= From: Laurent Pinchart To: libcamera-devel@lists.libcamera.org Date: Tue, 11 Dec 2018 21:10:06 +0200 Message-Id: <20181211191011.6315-2-laurent.pinchart@ideasonboard.com> X-Mailer: git-send-email 2.19.2 In-Reply-To: <20181211191011.6315-1-laurent.pinchart@ideasonboard.com> References: <20181211191011.6315-1-laurent.pinchart@ideasonboard.com> MIME-Version: 1.0 Subject: [libcamera-devel] [PATCH 1/6] build: Clean up file names variables X-BeenThere: libcamera-devel@lists.libcamera.org X-Mailman-Version: 2.1.23 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Tue, 11 Dec 2018 19:09:40 -0000 The build system defines two variables, public_api and sources, that store the names of the public headers and the source files respectively. These files will need to be referenced when generating documentation from source code, so let's make the variable names more descriptive: - Rename public_api to libcamera_api and use the files() function - Rename sources to libcamera_sources - Add a libcamera_headers variable to hold the internal headers Signed-off-by: Laurent Pinchart --- include/libcamera/meson.build | 6 +++--- src/libcamera/meson.build | 9 +++++++-- 2 files changed, 10 insertions(+), 5 deletions(-) diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build index 8fb21e983832..8c82675a25d2 100644 --- a/include/libcamera/meson.build +++ b/include/libcamera/meson.build @@ -1,6 +1,6 @@ -public_api = [ +libcamera_api = files([ 'libcamera.h', -] +]) -install_headers(public_api, +install_headers(libcamera_api, subdir : 'libcamera') diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build index fe38f8b2b5b4..0c44b5ab58fb 100644 --- a/src/libcamera/meson.build +++ b/src/libcamera/meson.build @@ -1,14 +1,19 @@ -sources = files([ +libcamera_sources = files([ 'log.cpp', 'main.cpp', ]) +libcamera_headers = files([ + 'include/log.h', + 'include/utils.h', +]) + includes = [ libcamera_includes, include_directories('include'), ] libcamera = shared_library('camera', - sources, + libcamera_sources, install : true, include_directories : includes)